Grammarly for Microsoft Word on Mac system requirements

The following system requirements must be met in order to run Grammarly for Microsoft Word on your Mac: 

  • A compatible operating system: macOS Catalina (10.15), macOS Mojave (10.14), or macOS High Sierra (10.13)
  • A compatible version of Microsoft Office: 16 or higher

To check your macOS version, click the Apple icon in the upper right corner of the screen and choose About This Mac:

About_this_Mac.png

To check your version of Microsoft Office, please open Microsoft Word, choose the Word menu, and click About Microsoft Word:

About_Word.png

Was this article helpful?
Have more questions? Submit a request