I can't install Grammarly for Microsoft Office

Prior to installing Grammarly for Microsoft Office, make sure that the following system requirements are met:

  • Compatible operating systems: Windows 7 Service Pack 1, Windows 8 and 8.1, Windows 10
  • Microsoft .NET Framework 4.6.2
  • Microsoft Office: 2007, 2010, 2013, 2016, or 2019

Note: Grammarly for Microsoft Office can be used with an Office 365 subscription as long as your plan provides one of the supported Microsoft Office versions.

If your computer is compatible with Grammarly but you still experience issues with installing the add-in, check the instructions below. 

If you see one of the error messages provided below, something on your PC might be blocking the installation or you might not have the administrative privileges to perform the installation. Follow the steps below to resolve the issue. 

Was this article helpful?
Have more questions? Submit a request
answer-bot