How to update Grammarly for Safari to the latest version

If you receive a notification that says "Update required! Safari won't support this version of Grammarly soon" or "Safari doesn't support this version of Grammarly anymore", please follow these steps:

  1. Click the Download button at www.grammarly.com/safari 
  2. Open the Apple Store and click Get:

    Screen_Shot_2019-05-23_at_3.22.58_PM.png
  3. Then, press Install:

    Screen_Shot_2019-05-23_at_3.24.22_PM.png
  4. Authenticate when prompted:

    Screen_Shot_2019-05-23_at_3.25.19_PM.png
  5. Wait for the download to finish, then click Open:

    Screen_Shot_2019-05-23_at_6.18.41_PM.png

Note: Grammarly for Safari is currently available on macOS Sierra 10.12.6, macOS High Sierra 10.13.6, macOS Mojave, and macOS Catalina. These versions of macOS are compatible with Safari 12 and newer.

 

Was this article helpful?
Have more questions? Submit a request
safari addon plugin extension update no-index latest version safari extension safari update safari issue browser plugin safari plugin safari addon